Network×Network目次

スポンサードリンク

Cisco コマンド再表示 logging synchronous

Cisco コマンド再表示 logging synchronous

Catalystなどを設定してるときにメッセージが表示されて
しまい入力中のコマンドが台無しになることがよくある。

そんなときはこれ!
-------------------------- 
◆コンソール
Switch(config)#line con 0
Switch(config-line)#logging synchronous
Switch(config-line)#exit

◆Telnet
Switch(config)#line vty 0 4
Switch(config-line)#logging synchronous
Switch(config-line)#exit
--------------------------

これで自動的にコマンドを復元してくれます。便利。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco default interface

Cisco Catalystスイッチポートの設定を
初期化したいときに便利なコマンド。

1.初期化ポート確認
!
interface GigabitEthernet1/0/6
switchport access vlan 10
switchport mode access
spanning-tree portfast
!

2.初期化
Switch(config)#default int g1/0/6
Interface GigabitEthernet1/0/6 set to default configuration
Switch(config)#

3.確認
!
interface GigabitEthernet1/0/6
!
これでGigabitEthernet1/0/6ポートのみ
初期化することができます。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

CISCO 半二重 エラー

CISCOのCatalystスイッチのポートを半二重設定に
したときはカウンタのエラーが増加する。

<CISCOホームページ参照>
Frame Check Sequence(FCS; フレーム チェック シーケンス)、
アライメント、ラント、およびコリジョンのカウンタで
データ リンク エラーが増加することは問題ありません。

一般的に、半二重接続の場合、総トラフィックに対して
エラーの比率が 1 パーセントであれば許容されます。
入力パケットに対するエラーの比率が2%や3%よりも
大きいと、パフォーマンスの低下に気づく場合があります。
<ここまで>

多少のエラーは許されるようです。
ただ接続先の設定も同じように半二重設定になっていないと
色々と問題が発生します。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

unknown protocol drops CISCO Router

Ciscoのルーターでshow interfaceコマンドで確認したところ
unknown protocol dropsエラーが大量にでている。

そこでCiscoのサイトで確認してみたところ、
「認識できないプロトコルのパケットを検出した場合にカウント。
例えば、CDPを有効にしたインターフェースと無効にした
インターフェースを相互接続すると発生する」

などの原因が書かれている。
確認したところ、
L2 Switch ⇒ CDP有効
Router ⇒ CDP無効
になっていた。

CDPは基本的に無効でよい。
シスコ検出プロトコルなんだけど別に必要でない。
というか今回みたいなエラーを起こす場合がある。

◆無効
(config)#no cdp run

◆有効
(config)#cdp run

◆ポート単位で有効
(config)#int g0/10
(config-if)#cdp run

◆CDP送信間隔
(config)#cdp timer 120
※デフォルトは60秒

(config)#no cdp timer
※デフォルトに戻る

◆CDPホールドタイム
(config)#cdp holdTime 255
※デフォルトは180秒

(config)#no cdp holdTime
※デフォルトに戻る

◆CDP情報の表示
(config)#show cdp

(config)#show cdp neighbors

ちなみにCDPは基本デフォルト有効です。
とりあえずCDP必要なければ無効にしておきましょう!!
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco ポート オレンジ 点灯

Ciscoのスイッチでポートがオレンジ色に点灯して
いるのでエラーが発生しているのかと思った。

よくよく調べてみるとスパニングツリーのブロッキングポート
に設定されているだけで正常な動作でした。

あせらなーい、あせらない。。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

CISCO 端末型払い出し ISDN

CISCO892JをISDN接続してIPを相手ルーターから
振り出してもらう場合の設定参考例。
かなりハマりました。

ポイント1
BRIインターフェースでIPアドレスを振り出してもらう設定
ip address negotiated

ポイント2
NATの設定

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
hostname TEST-A
!
ip subnet-zero
!
ip cef
!
interface FastEthernet0
no ip address
duplex auto
speed auto
pppoe enable
pppoe-client dial-pool-number 1

!
!
interface Vlan1
ip address 192.168.1.254 255.255.255.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1414

!
interface Dialer1
ip address negotiated
ip mtu 1454
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap callin
ppp chap hostname TEST-B[相手のホスト名]
ppp chap password 0 cisco

!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
ip nat inside source list 1 interface Dialer1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
dialer-list 1 protocol ip permit

!

=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*

◆確認コマンド
IPアドレス振り出しコマンド
show ip int brief
show ip route

◆PPPoE確認コマンド
show pppoe session
show pppoe session all

◆NAT確認コマンド
show ip nat translations

◆ISDN確認コマンド
show isdn active
show isdn status
show isdn history
show isdn history detail

◆Debugコマンド
debug ppp authentication
debug isdn ***
など
※debugコマンドを使用するときは注意が必要。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(1) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco ACL コメント挿入

remarkを使用するとACLエントリにコメントを追加することができる。

Cisco(config)#access-list 1 remark Permit only Workstation_Seg
Cisco(config)#access-list 1 permit 192.168.1.0 0.0.0.255
Cisco(config)#access-list 1 deny any

このようにremarkコマンドを使うと何用の
アクセスリストかわかりやすくなります。

TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco Aironetの読み方

CiscoのAironetは無線APとしてかなりメジャーですが
読み方が微妙にわからなかった。

Aironetと書いて[エアロネット]と読むみたいです。
CISCOのページにもたまに書いてあるので間違いないでしょう。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco Aironet dhcp 設定

Cisco Aironetシリーズの無線AP自体をDHCPサーバに
設定してみようとしたところWEBでは設定項目が
見つからない。

しょうがないのでコンソールから設定した。

AP#configure terminal
AP(config)#ip dhcp excluded-address 192.168.1.100
↑除外するIPアドレス
AP(config)#ip dhcp pool ClientDHCP
↑DHCPプール名
AP(dhcp-config)#network 192.168.1.0 255.255.255.0
AP(dhcp-config)#lease 10
↑貸出期間(日)
AP(dhcp-config)#default-router 192.168.1.254
↑上位ルータ
AP(dhcp-config)#end

これでクライアントPCを無線APに接続したらIPアドレスを
取得することができました。

TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco Aironet bvi interface

Cisco Aironetシリーズの自律型無線AP
LAN接続しようとしてもできない。

[interface GigabitEthernet0]というポートにIPを設定
してるのだが全然PINGが飛ばない。

しらべてみたところAironetシリーズのEthernetポートに
接続する場合BVIにIPアドレスを設定しないといけないようだ。

(config)#interface BVI1
(config-if)#ip address 192.168.1.1 255.255.255.0

これでPCに192.168.1.100を設定してPINGしたところ
やっと飛ぶようになった。無事WEB接続もできた。

ちなみに初期パスワードはこちら

TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする