Network×Network目次

スポンサードリンク

Catalyst vlan trunk 追加

Catalyst機のポートg1/0/1に設定してるvlan trunkに新しいvlanを
追加したいときはaddコマンド。

1.確認
Cat#sh run
interface g1/0/1
switchport trunk allowed vlan 10,20

2.追加
Cat#conf t
Cat(config)#int vlan 30
Cat(config)#int g1/0/1
Cat(config-if)#switchport trunk allowed vlan add 30

3.設定確認
Cat#sh run
interface g1/0/1
switchport trunk allowed vlan 10,20,30

これでvlan 30が追加されました。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Catalyst 設定保存 コマンド

Catalystを久しぶりに設定。本当に久しぶり。
どれくらい久しぶりかと言うと保存コマンドを忘れるくらい。

楽だからということでいつもは、
Cisco#write memory

さらに省略したコマンド
Cisco#wr
ちょっとCisco機に触ってなれてくると
みんなこれで保存しちゃいますよね。

久しぶりにコピーコマンドで設定保存しようとしたら
コマンドを覚えていなくてあせりました。メモ代わり。
Cisco#copy running-config start-config

省略系は
Cisco#copy run start

上記4つのコマンドは意味は同じです。
現在設定した内容をメモリに保存するというコマンド。

似たようなコマンドで、
Cisco#copy start-config running-config
Cisco#copy start run
などがあるがこれは保存されているメモリの設定を
現在の設定として上書きするというコマンド。

いやーおっさんになると咄嗟には出てこなくなりますねー
あと資料ばっかり作ってて作業しなくなると技術力は
衰える一方です・・・・。。。



TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco reset snmp counters

clear countersコマンドでCatalystスイッチのポートカウンタをリセットした。
けどSNMPの値はなぜかリセットされない。どゆこと?

以下CISCOのホームページ参照
-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
Q. SNMP カウンタが CLI の show コマンドと
同じ数値を返さないのはなぜですか。

A. カウンタとして定義されている SNMP オブジェクトは、
次に示す RFC1155 leavingcisco.com(正式定義は英文)
に準拠している必要があります。

「3.2.3.3. カウンタ
このアプリケーションワイドのタイプは負でない整数を表し、
最大値に達するまで単調に増加し続ける。その後、カウンタは
ラップアラウンドしてゼロから再度開始される。この規約では、
カウンタの最大値を 2^32-1(10 進数で 4294967295)と定義する。」

デバイスをリロードせずに SNMP カウンタを
ゼロにリセットする方法はありません。

-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-

再起動するしかないんか・・・・
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco ミラーポート設定

お客様にWANで流れているトラフィックをキャプチャ
したいと言われた。そんな時はミラーポートである。
CiscoでいうところのSPAN(Switched Port Analyzer)。

LAN線の物理接続変更などを行わずにパケットキャプチャ
を実行することが可能となる。

◆スイッチにミラーポート設定
3550(config)#monitor session 1 source interface f0/1
←パケットキャプチャしたいポートを指定
3550(config)#monitor session 1 destination interface f0/2
←複製を作成(ここでキャプチャが行えます)

◆さらに複製するポートは複数追加可能
3550(config)#monitor session 1 destination interface f0/3
3550(config)#monitor session 1 destination interface f0/8
←f0/3と8ポートでもパケットキャプチャが可能となる。

◆パケットキャプチャするための準備
パケットキャプチャするためにはPCに
ソフトをインストールして行いましょう!
お薦めはWIRESHARK
https://www.wireshark.org/download.html

◆注意点
sourceポートは最大2つまでしか作成できません!!
3550(config)#monitor session 1 source interface f0/1
3550(config)#monitor session 1 destination interface f0/2

3550(config)#monitor session 2 source interface f0/10
3550(config)#monitor session 2 destination interface f0/11

3つ目が作成したい場合はsession1か2を削除する必要がある。
3550(config)#monitor session 3 source interface f0/20
3550(config)#monitor session 3 destination interface f0/22

TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco CDP 設定

Ciscoの独自プロトコルCDP。
これはデフォルトオンとなっています。
基本オフにしてしまって問題ないです。

すべての機器がCisco製品で情報取得に
CDPを使う場合はオンでもいいかも。
それでもやっぱオフかな!!

◆無効
(config)#no cdp run

◆有効
(config)#cdp run

◆ポート単位で有効
(config)#int g0/10
(config-if)#cdp run

◆CDP送信間隔
(config)#cdp timer 120
※デフォルトは60秒

(config)#no cdp timer
※デフォルトに戻る

◆CDPホールドタイム
(config)#cdp holdTime 255
※デフォルトは180秒

(config)#no cdp holdTime
※デフォルトに戻る

◆CDP情報の表示
(config)#show cdp

(config)#show cdp neighbors

TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

CISCO 純正品 USBコンソールケーブル


CISCO 純正品 USBコンソールケーブル

USBのシスココンソールケーブルもあるんだな。
これほしーけど高いわ〜
案件に紐づけて買うしかないな!!
仕事のためです♪

TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Catalyst4500 reload バグ

Catalyst4500でshow techをたたいたところ
スイッチがリロードしました。
お客様先で真っ青になっております。

どーやらバグのようですね。
Catalyst 4500 シリーズスイッチで、特定の条件下で show tech-support コマンド、
またはshow platform hardware interface all コマンドの実行時に、
予期しないリロードが発生する


これならしょうがないね。ってなんでやねん!!
show techでリロードしてたら話にならんわ!

まー実際はshow techに含まれている
show platform hardware interface all
というコマンドが悪さしてるみたいだけど・・・

いちいちこんなバグ情報調べてないし。
これからはshow techでログ取得するのも命懸けだな〜



TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

CISCO 純正品 コンソールケーブル


CISCO 純正品 コンソールケーブル/72-3383-01 RJ-45 DB-9

シスコルータに付属してるコンソールケーブルって
こんな高いんだ!!ちょっとびっくりした〜
しかも今や別売り〜ありえないね。

昔はタダだったのに時代は変わったんだな・・・・
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco show run more 検索

Cisco show run more 検索

sh runの途中で検索を行う方法。
sh runの途中で--More--と表示されたときに/[検索する文字]
を入力するとその行まで飛びます。

これ意外と知ってる人少ないんじゃ!?

◆使用例
#sh run
Building configuration...

Current configuration : 4168 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Switch
!
boot-start-marker
boot-end-marker
!
enable secret ******
!
!
!
no aaa new-model
clock timezone JST 9
system mtu routing 1500
ip routing
--More--/vty

filtering...

line vty 0 4
password 7 878787878787878
login
line vty 5 15
no login
!
end

途中でfiltering...検索されてますね。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Cisco DHCP relay

Cisco機器でDHCPリレーを行うときは
ip helper-address コマンドを使う。

これはサーバが別のセグメントなどにある
場合設定するコマンドである。

cisco ip helper-address
ip helper-addressはDHCPクライアントが
存在するvlanで行うこと。

<設定例>
Router(Config)#int vlan 20
Router(Config-if)#ip helper-address 192.168.1.11

これでセグメントを超えてDHCPアドレスを聞きに
いってくれるはずです!


TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Cisco | このブログの読者になる | 更新情報をチェックする