Network×Network目次

スポンサードリンク

NEXUS NX-OS feature機能の有効無効

Cisco NEXUSではデフォルトで多くの機能やプロトコルが無効となっている。
使用するためには有効にする必要がある。

以下がNX-OS9.3(2)のfeature機能の有効化/無効化のデフォルト状態となる。
機種は3000番台。
-----------------------------------------------------------
sh feature
Feature Name Instance State
-------------------- -------- --------
Flexlink 1 disabled
analytics 1 disabled
bash-shell 1 disabled
bfd 1 disabled
bgp 1 disabled
bulkstat 1 disabled
cable-management 1 disabled
catena 1 disabled
container-tracker 1 disabled
macsec 1 disabled
dhcp 1 disabled
dot1x 1 disabled
eigrp 1 disabled
eigrp 2 disabled
eigrp 3 disabled
eigrp 4 disabled
eigrp 5 disabled
eigrp 6 disabled
eigrp 7 disabled
eigrp 8 disabled
eigrp 9 disabled
eigrp 10 disabled
eigrp 11 disabled
eigrp 12 disabled
eigrp 13 disabled
eigrp 14 disabled
eigrp 15 disabled
eigrp 16 disabled
eth-port-sec 1 disabled
evb 1 disabled
evc 1 disabled
evmed 1 disabled
fabric-access 1 disabled
fabric_mcast 1 disabled
grpc 1 disabled
hardware-telemetry 1 disabled
hmm 1 disabled
hsrp_engine 1 disabled
icam 1 disabled
imp 1 disabled
interface-vlan 1 disabled
isis 1 disabled
isis 2 disabled
isis 3 disabled
isis 4 disabled
isis 5 disabled
isis 6 disabled
isis 7 disabled
isis 8 disabled
isis 9 disabled
isis 10 disabled
isis 11 disabled
isis 12 disabled
isis 13 disabled
isis 14 disabled
isis 15 disabled
isis 16 disabled
itd 1 disabled
l2vpn 1 disabled
l3vpn 1 disabled
lacp 1 disabled
ldap 1 disabled
ldp 1 disabled
license-smart 1 disabled
lldp 1 enabled
mpls-evpn 1 disabled
mpls_oam 1 disabled
mpls_static 1 disabled
msdp 1 disabled
mvrp 1 disabled
nat 1 disabled
nbm 1 disabled
netconf 1 disabled
ngmvpn 1 disabled
ngoam 1 disabled
npiv 1 disabled
nve 1 disabled
nxapi 1 disabled
nxsdk_app1 1 disabled
nxsdk_app10 1 disabled
nxsdk_app11 1 disabled
nxsdk_app12 1 disabled
nxsdk_app13 1 disabled
nxsdk_app14 1 disabled
nxsdk_app15 1 disabled
nxsdk_app16 1 disabled
nxsdk_app17 1 disabled
nxsdk_app18 1 disabled
nxsdk_app19 1 disabled
nxsdk_app2 1 disabled
nxsdk_app20 1 disabled
nxsdk_app21 1 disabled
nxsdk_app22 1 disabled
nxsdk_app23 1 disabled
nxsdk_app24 1 disabled
nxsdk_app25 1 disabled
nxsdk_app26 1 disabled
nxsdk_app27 1 disabled
nxsdk_app28 1 disabled
nxsdk_app29 1 disabled
nxsdk_app3 1 disabled
nxsdk_app30 1 disabled
nxsdk_app31 1 disabled
nxsdk_app32 1 disabled
nxsdk_app4 1 disabled
nxsdk_app5 1 disabled
nxsdk_app6 1 disabled
nxsdk_app7 1 disabled
nxsdk_app8 1 disabled
nxsdk_app9 1 disabled
nxsdk_mgr 1 disabled
onep 1 disabled
openflow 1 disabled
ospf 1 disabled
ospf 2 disabled
ospf 3 disabled
ospf 4 disabled
ospf 5 disabled
ospf 6 disabled
ospf 7 disabled
ospf 8 disabled
ospf 9 disabled
ospf 10 disabled
ospf 11 disabled
ospf 12 disabled
ospf 13 disabled
ospf 14 disabled
ospf 15 disabled
ospf 16 disabled
ospfv3 1 disabled
ospfv3 2 disabled
ospfv3 3 disabled
ospfv3 4 disabled
ospfv3 5 disabled
ospfv3 6 disabled
ospfv3 7 disabled
ospfv3 8 disabled
ospfv3 9 disabled
ospfv3 10 disabled
ospfv3 11 disabled
ospfv3 12 disabled
ospfv3 13 disabled
ospfv3 14 disabled
ospfv3 15 disabled
ospfv3 16 disabled
pbr 1 disabled
pim 1 disabled
pim6 1 disabled
plb 1 disabled
poe 1 disabled
private-vlan 1 disabled
privilege 1 disabled
ptp 1 disabled
restconf 1 disabled
rip 1 disabled
rip 2 disabled
rip 3 disabled
rip 4 disabled
rise 1 disabled
scheduler 1 disabled
scpServer 1 disabled
segment-routing 1 disabled
sflow 1 disabled
sftpServer 1 disabled
sla_responder 1 disabled
sla_sender 1 disabled
sla_twamp 1 disabled
smart-channel 1 disabled
srte 1 disabled
srv6 1 disabled
sshServer 1 enabled
tacacs 1 disabled
telemetry 1 disabled
telnetServer 1 disabled
tunnel 1 disabled
udld 1 disabled
vmtracker 1 disabled
vni 1 disabled
vnseg_vlan 1 disabled
vpc 1 disabled
vrrp 1 disabled
vrrpv3 1 disabled
vtp 1 disabled
switch#
-----------------------------------------------------------

feature機能の有効化/無効化は以下のコマンドで。
■有効化
switch#configure terminal
switch(config)#feature ssh

■無効化
switch#configure terminal
switch(config)#no feature ssh

以上。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | Cisco | このブログの読者になる | 更新情報をチェックする

NEXUS NX-OS デフォルトコンフィグ

CISCO NEXUSスイッチのデフォルトコンフィグが
知りたくてGoogle検索したけどなかったので、( ..)φメモメモ。

以下はNX-OS9.3(2)のデフォルトコンフィグとなります。
機種は3000番台。
-------------------------------------------------------------------------
switch# sh run

!Command: show running-config
!Running configuration last done at: Wed May 01 00:00:00 2020
!Time: Wed May 01 00:00:00 2020

version 9.3(2) Bios:version 5.3.1
vdc switch id 1
limit-resource vlan minimum 16 maximum 4094
limit-resource vrf minimum 2 maximum 4096
limit-resource port-channel minimum 0 maximum 104
limit-resource u4route-mem minimum 128 maximum 128
limit-resource u6route-mem minimum 96 maximum 96
limit-resource m4route-mem minimum 58 maximum 58
limit-resource m6route-mem minimum 8 maximum 8
feature lldp

no password strength-check
username admin password 5 ! role network-admin
ip domain-lookup
service unsupported-transceiver
ip access-list copp-system-acl-eigrp
10 permit eigrp any 224.0.0.10/32
ipv6 access-list copp-system-acl-eigrp6
10 permit eigrp any ff02::a/128
ip access-list copp-system-acl-icmp
10 permit icmp any any
ip access-list copp-system-acl-igmp
10 permit igmp any any
ip access-list copp-system-acl-ntp
10 permit udp any any eq ntp
20 permit udp any eq ntp any
ip access-list copp-system-acl-pimreg
10 permit pim any any
ip access-list copp-system-acl-ping
10 permit icmp any any echo
20 permit icmp any any echo-reply
ip access-list copp-system-acl-routingproto1
10 permit tcp any gt 1024 any eq bgp
20 permit tcp any eq bgp any gt 1024
30 permit udp any 224.0.0.0/24 eq rip
40 permit tcp any gt 1024 any eq 639
50 permit tcp any eq 639 any gt 1024
70 permit ospf any any
80 permit ospf any 224.0.0.5/32
90 permit ospf any 224.0.0.6/32
ip access-list copp-system-acl-routingproto2
10 permit udp any 224.0.0.0/24 eq 1985
20 permit 112 any 224.0.0.0/24
ip access-list copp-system-acl-snmp
10 permit udp any any eq snmp
20 permit udp any any eq snmptrap
ip access-list copp-system-acl-ssh
10 permit tcp any any eq 22
20 permit tcp any eq 22 any
ip access-list copp-system-acl-stftp
10 permit udp any any eq tftp
20 permit udp any any eq 1758
30 permit udp any eq tftp any
40 permit udp any eq 1758 any
50 permit tcp any any eq 115
60 permit tcp any eq 115 any
ip access-list copp-system-acl-tacacsradius
10 permit tcp any any eq tacacs
20 permit tcp any eq tacacs any
30 permit udp any any eq 1812
40 permit udp any any eq 1813
50 permit udp any any eq 1645
60 permit udp any any eq 1646
70 permit udp any eq 1812 any
80 permit udp any eq 1813 any
90 permit udp any eq 1645 any
100 permit udp any eq 1646 any
ip access-list copp-system-acl-telnet
10 permit tcp any any eq telnet
20 permit tcp any any eq 107
30 permit tcp any eq telnet any
40 permit tcp any eq 107 any
ipv6 access-list copp-system-acl-v6routingProto2
10 permit udp any ff02::66/128 eq 2029
20 permit udp any ff02::fb/128 eq 5353
30 permit 112 any ff02::12/128
40 permit pim any ff02::d/128
ipv6 access-list copp-system-acl-v6routingproto1
10 permit 89 any ff02::5/128
20 permit 89 any ff02::6/128
30 permit udp any ff02::9/128 eq 521
ip access-list copp-system-dhcp-relay
10 permit udp any eq bootps any eq bootps
class-map type control-plane match-any copp-icmp
match access-group name copp-system-acl-icmp
class-map type control-plane match-any copp-ntp
match access-group name copp-system-acl-ntp
class-map type control-plane match-any copp-s-arp
class-map type control-plane match-any copp-s-bfd
class-map type control-plane match-any copp-s-bpdu
class-map type control-plane match-any copp-s-dai
class-map type control-plane match-any copp-s-default
class-map type control-plane match-any copp-s-dhcpreq
class-map type control-plane match-any copp-s-dhcpresp
match access-group name copp-system-dhcp-relay
class-map type control-plane match-any copp-s-dpss
class-map type control-plane match-any copp-s-eigrp
match access-group name copp-system-acl-eigrp
match access-group name copp-system-acl-eigrp6
class-map type control-plane match-any copp-s-glean
class-map type control-plane match-any copp-s-igmp
match access-group name copp-system-acl-igmp
class-map type control-plane match-any copp-s-ipmcmiss
class-map type control-plane match-any copp-s-l2switched
class-map type control-plane match-any copp-s-l3destmiss
class-map type control-plane match-any copp-s-l3mtufail
class-map type control-plane match-any copp-s-l3slowpath
class-map type control-plane match-any copp-s-mpls
class-map type control-plane match-any copp-s-pimautorp
class-map type control-plane match-any copp-s-pimreg
match access-group name copp-system-acl-pimreg
class-map type control-plane match-any copp-s-ping
match access-group name copp-system-acl-ping
class-map type control-plane match-any copp-s-ptp
class-map type control-plane match-any copp-s-routingProto1
match access-group name copp-system-acl-routingproto1
match access-group name copp-system-acl-v6routingproto1
class-map type control-plane match-any copp-s-routingProto2
match access-group name copp-system-acl-routingproto2
class-map type control-plane match-any copp-s-selfIp
class-map type control-plane match-any copp-s-ttl1
class-map type control-plane match-any copp-s-v6routingProto2
match access-group name copp-system-acl-v6routingProto2
class-map type control-plane match-any copp-s-vxlan
class-map type control-plane match-any copp-snmp
match access-group name copp-system-acl-snmp
class-map type control-plane match-any copp-ssh
match access-group name copp-system-acl-ssh
class-map type control-plane match-any copp-stftp
match access-group name copp-system-acl-stftp
class-map type control-plane match-any copp-tacacsradius
match access-group name copp-system-acl-tacacsradius
class-map type control-plane match-any copp-telnet
match access-group name copp-system-acl-telnet
policy-map type control-plane copp-system-policy
class copp-s-default
police pps 400
class copp-s-l2switched
police pps 200
class copp-s-ping
police pps 100
class copp-s-l3destmiss
police pps 100
class copp-s-glean
police pps 500
class copp-s-selfIp
police pps 500
class copp-s-l3mtufail
police pps 100
class copp-s-ttl1
police pps 100
class copp-s-ipmcmiss
police pps 400
class copp-s-l3slowpath
police pps 100
class copp-s-dhcpreq
police pps 300
class copp-s-dhcpresp
police pps 300
class copp-s-dai
police pps 300
class copp-s-igmp
police pps 400
class copp-s-eigrp
police pps 200
class copp-s-pimreg
police pps 200
class copp-s-pimautorp
police pps 200
class copp-s-routingProto2
police pps 1300
class copp-s-v6routingProto2
police pps 1300
class copp-s-routingProto1
police pps 1000
class copp-s-arp
police pps 200
class copp-s-ptp
police pps 1000
class copp-s-vxlan
police pps 1000
class copp-s-bfd
police pps 900
class copp-s-bpdu
police pps 12000
class copp-s-dpss
police pps 1000
class copp-s-mpls
police pps 100
class copp-icmp
police pps 200
class copp-telnet
police pps 500
class copp-ssh
police pps 500
class copp-snmp
police pps 500
class copp-ntp
police pps 100
class copp-tacacsradius
police pps 400
class copp-stftp
police pps 400
control-plane
service-policy input copp-system-policy
snmp-server user admin network-admin
rmon event 1 log trap public description FATAL(1) owner PMON@FATAL
rmon event 2 log trap public description CRITICAL(2) owner PMON@CRITICAL
rmon event 3 log trap public description ERROR(3) owner PMON@ERROR
rmon event 4 log trap public description WARNING(4) owner PMON@WARNING
rmon event 5 log trap public description INFORMATION(5) owner PMON@INFO

vlan 1
vrf context management
hardware profile portmode 48X10G+breakout6x40g



interface Ethernet1/1

interface Ethernet1/2

interface Ethernet1/3

interface Ethernet1/4

interface Ethernet1/5

interface Ethernet1/6

interface Ethernet1/7

interface Ethernet1/8

interface Ethernet1/9

interface Ethernet1/10

interface Ethernet1/11

interface Ethernet1/12

interface Ethernet1/13

interface Ethernet1/14

interface Ethernet1/15

interface Ethernet1/16

interface Ethernet1/17

interface Ethernet1/18

interface Ethernet1/19

interface Ethernet1/20

interface Ethernet1/21

interface Ethernet1/22

interface Ethernet1/23

interface Ethernet1/24

interface Ethernet1/25

interface Ethernet1/26

interface Ethernet1/27

interface Ethernet1/28

interface Ethernet1/29

interface Ethernet1/30

interface Ethernet1/31

interface Ethernet1/32

interface Ethernet1/33

interface Ethernet1/34

interface Ethernet1/35

interface Ethernet1/36

interface Ethernet1/37

interface Ethernet1/38

interface Ethernet1/39

interface Ethernet1/40

interface Ethernet1/41

interface Ethernet1/42

interface Ethernet1/43

interface Ethernet1/44

interface Ethernet1/45

interface Ethernet1/46

interface Ethernet1/47

interface Ethernet1/48

interface Ethernet1/49
no shutdown

interface Ethernet1/50
no shutdown

interface Ethernet1/51
no shutdown

interface Ethernet1/52
no shutdown

interface Ethernet1/53
no shutdown

interface Ethernet1/54
no shutdown

interface mgmt0
vrf member management
line console
line vty
boot nxos bootflash:/nxos.9.3.2.bin

switch#
-------------------------------------------------------------------------

コントロール プレーン ポリシング(CoPP)ってのがやたらと
行数をくってるな。Catalystにはなかった概念。

もとのコンフィグがわからないと不便なことが多いと
思った今日この頃。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | Cisco | このブログの読者になる | 更新情報をチェックする

Fortigate FortiOS Upgrade Paths

Fortigate社のファームウェアアップグレードパスを
教えてくれるツールなんて今ではあるんですね。

Current Product : 対象製品
Current FortiOS Version : 現在のOSバージョン
Upgrade to FortiOS Version : アップグレードしたOSバージョン
GO

WS000133.JPG

こりゃ便利ですね。
-------------------------------------------------------------
Fortigateのファームウェアアップデートパスとなります。
ちゃんとベンダーが推奨してる方法を実施してFortiOSの
アップグレードを行いましょう!!
Fortigate FortiOS Upgrade Paths

古いファームウェアほど多くのFortiOSファームウェア
アップデートパスを踏む必要があるのでちゃんと
Fortinetクックブックで確認しましょう!

Supported Upgrade Paths – FortiOS

Supported Upgrade Paths – FortiOS Upgrading to 5.4



TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | Fortigate | このブログの読者になる | 更新情報をチェックする

MD5 windows 確認方法

ダウンロードしたファイルが壊れてたりしたら嫌ですよね。
そんなときはMD5のハッシュ値を確認しましょう。

何じゃそりゃって方もいるかもしれませんが用は
同じ物からは手を加えられてない限り同じ値のハッシュ値が得られるということ。

[例]
ダウンロードする前のMD5ハッシュの値
5d0ee2b4fdde20557ef8f6f50db2356f

ダウンロード後のMD5ハッシュの値
5d0ee2b4fdde20557ef8f6f50db2356f ⇒OK
8dfd623994a234e4eeeebbbbaaaaa238 ⇒NG

一緒だとOK、違ったらファイルが破損してる可能性大。
また誰かが改ざんしてる場合もハッシュ値は変わります。

じゃそんなハッシュ値を確認するためには何かツールがいるのだろうか。
いやいやレジストリをちょいちょいといじれば右クリックでMD5ハッシュ値
はわかるようになります。

[md5 windows設定方法]
1.下記内容をコピーしてテキストに貼り付けます。
-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\MD5]
@="MD&5copy"

[HKEY_CLASSES_ROOT\*\shell\MD5\command]
@="cmd /c certutil -hashfile \"%1\" MD5|findstr -v \":\"|clip"

[HKEY_CLASSES_ROOT\*\shell\SHA1]
@="SHA&1copy"

[HKEY_CLASSES_ROOT\*\shell\SHA1\command]
@="cmd /c certutil -hashfile \"%1\" SHA1|findstr -v \":\"|clip"
-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-

2.テキストの名前を[MD5.reg]に変更
MD5 ハッシュ値

3.[MD5.reg]をダブルクリック
続行しますかと出るので[はい]
「キーと値が、レジストリに正常に追加されました。」
とで表示されればOK

以上で設定は終了です。
次はハッシュ値を確認していきましょう。

[md5 windows確認方法]
1.多くのダウンロードサイトではMD5ハッシュ値も準備されているので
それをダウンロードしましょう。ここではF5のサイトを参照。
MD5 ハッシュ値
BIGIP-11.5.3.0.0.163.iso(今回使用したいファイル)
BIGIP-11.5.3.0.0.163.iso.md5(上記ファイルのMD5ファイル)

2.ダウンロードしたMD5ファイルをテキストで開きます。
3.使用したいファイルを右クリック[MD5をコピー]
MD5 ハッシュ値

真っ黒なコマンドプロンプトが開いて自動的に閉じたら終了です。

4.さきほどテキストで開いたMD5ファイルに貼り付け。
MD5 ハッシュ値
この値が同じであれば全く同じファイルとみなすことができます。

安心してダウンロードしたファイルが使用できますね。。
windows7及びwindows10でも正常に動作しました。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | PC | このブログの読者になる | 更新情報をチェックする

VISIOステンシル まとめ一覧

VISIOステンシル まとめ一覧
-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
クラウド VISIO STENCILS まとめ
[Amazon]
*Amazon Web Services VISIO ステンシル
AWS シンプルアイコン VISIOステンシル一覧

[Microsoft]
*Microsoft AZURE VISIO ステンシル
Microsoft Azure, Cloud and Enterprise Symbol / Icon Set VISIOステンシル一覧

-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
NETWORK VISIO STENCILS まとめ
[CISCO]
*CISCO VISIO ステンシル
シスコ ネットワーク機器VISIOステンシル一覧

*CISCO ネットワークトポロジアイコン ステンシル
ネットワーク図を描くときに必要なステンシルセット

[FORTINET]

*FORTIGATE VISIO ステンシル
フォーティゲート ネットワーク機器VISIOステンシル一覧

[Juniper]
*Juniper VISIO ステンシル
ジュニパー ネットワーク機器VISIOステンシル一覧

[Allied Telesis]

*Allied Telesis VISIO ステンシル
アライドテレシス ネットワーク機器VISIOステンシル一覧

[Hewlett Packard]
*3COM VISIO ステンシル
スリーコム ネットワーク機器VISIOステンシル一覧

*aruba VISIO ステンシル
アルーバ ネットワーク機器VISIOステンシル一覧

[BROCADE]
*BROCADE VISIO ステンシル
ブロケード ネットワーク機器VISIOステンシル一覧

[YAMAHA]
*YAMAHA VISIO ステンシル
ヤマハ ネットワーク機器VISIOステンシル一覧

[F5]
*F5 VISIO ステンシル
エフファイヴ ネットワーク機器VISIOステンシル一覧

[PaloAlto Networks]
*PaloAlto Networks VISIO ステンシル
パロアルトネットワークス ネットワーク機器VISIOステンシル一覧

[Hitachi Cable]
*Apresia VISIO ステンシル
アプレシア ネットワーク機器VISIOステンシル一覧

[Extreme Networks]
*Extreme Networks VISIO ステンシル
エクストリームネットワークス ネットワーク機器VISIOステンシル一覧

-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
SERVER VISIO STENCILS まとめ
[IBM]
*IBM VISIO ステンシル
アイビーエム 機器ステンシル一覧

[HP]
*HP VISIO ステンシル
ヒューレットパッカード 機器ステンシル一覧

[DELL]

*DELL VISIO ステンシル
デル 機器ステンシル一覧

[Fujitsu]
*Fujitsu VISIO ステンシル
富士通 機器ステンシル一覧

[NetApp]
*NettApp VISIO ステンシル
ネットアップ 機器ステンシル一覧
※登録が必要

*VISIO CAFEのNettApp VISIOステンシルは登録無でダウンロード可能

[EMC]
*Avamar VISIO ステンシル一覧
アバマー 機器ステンシル一覧

[AMAZON]
*AMAZON WEB SERVICES VISIO ステンシル一覧
アマゾンウェブサービス ステンシル一覧

[VMWARE]
*VMWARE VISIO ステンシル一覧
ブイエムウェア ステンシル一覧

[Microsoft]
*Hyper-V VISIO ステンシル一覧
ハイパーブイ ステンシル一覧

-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
OTHER VISIO STENCILS まとめ
[PANDUIT]
*PANDUIT VISIO ステンシル一覧
パンドウィット ステンシル一覧

[Polycom]
*Polycom VISIO ステンシル一覧
ポリコム ステンシル一覧

[ORACLE]
*ORACLE VISIO ステンシル一覧
オラクル ステンシル一覧

[APC]
*APC VISIO ステンシル一覧
エーピーシー ステンシル一覧

-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-*-
SITE VISIO STENCILS まとめ
[VISIO CAFE]
*言わずと知れたヴィジオカフェ。
有名メーカーのVISIOが各種勢ぞろい!!


[Visio.jp]
*電機・電子回路図系などちょっと他では
手に入りにくいVISIOがここではたくさん


[Hesonogoma Tips]
*VISIO画像が貼ってあって視覚的に
見ながらほしいVISIOステンシルを選べる


[Microsoft VISIOダウンロード]
*VISIOを提供してるマイクロソフト様の
無償ダウンロードサービス





TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | TrackBack(0) | まとめ一覧 | このブログの読者になる | 更新情報をチェックする

Catalyst terminal length 0

ネットワーク機器でコンフィグやログを取得するときに
数行表示されて止まるの鬱陶しくありませんか!?

Cisco機器では有名なコマンド「ターレンゼロ」というのがあります。
これ最初聞いたときは何の呪文かと思っていました。
コマンド途中でmoreと表示されて止まることなく最後まで
流れてくれるようになります。

Cisco以外の機器でもターレンゼロに相当するコマンドが
あるので( ..)φメモメモしときます。

◆CISCO
----------------------------------------------------------------
[Cisco IOS / NX-OS]
これがかの有名なターレンゼロコマンド
#terminal length 0

元に戻すときは表示する行数を入力
#terminal length 24

[Cisco ASA]
#terminal pager 0
#terminal pager 24

恒久的(コンフィグに書き込み)
#conf t
(conf)#pager lines 0

[Cisco Wireless LAN Controller(WLC)]
>config paging disable
>config paging enable
----------------------------------------------------------------

◆Juniper
----------------------------------------------------------------
[JUNOS]
>set cli screen-length 0
>set cli screen-length 24

コマンド単位で制御
>**** | no-more

[SSG]
>set console page 0
>unset console page
----------------------------------------------------------------

◆Fortinet
----------------------------------------------------------------
[FortiOS]
#config system console
(console)#set output standard
(console)#end

確認コマンド
#get system console
#show system console

元に戻すコマンド
#config system console
(console)#set output more
(console)#end

#config system console
(console)#unset output
(console)#end
----------------------------------------------------------------

◆YAMAHA
----------------------------------------------------------------
[RTX]
恒久的(コンフィグに書き込み)
>console lines infinity
>console lines 24
----------------------------------------------------------------

◆PaloAlto
----------------------------------------------------------------
[PAN-OS]
>set cli pager off
>set cli pager on
----------------------------------------------------------------

◆F5
----------------------------------------------------------------
[BIG-IP]
#yes | tmsh show running-config
#tmsh **** one-line

恒久的(コンフィグに書き込み)
#tmsh modify cli preference pager disabled
#tmsh modify cli preference pager enabled
----------------------------------------------------------------

◆NEC
----------------------------------------------------------------
[IX]
#config
(config)#terminal length 0
(config)#terminal length 24

[QX]
<QX>screen-length disable
<QX>screen-length 24
----------------------------------------------------------------

◆Alaxala
----------------------------------------------------------------
[AX]
恒久的(コンフィグに書き込み)
>set terminal pager disable
>set terminal pager enable
----------------------------------------------------------------

◆Brocade
----------------------------------------------------------------
[Network OS]
#terminal length 0
#no terminal length

[IronWare]
#skip-page-display
#page-display
----------------------------------------------------------------

◆CheckPoint
----------------------------------------------------------------
[GAiA]
#set clienv rows 0
#set clienv rows 24

恒久的(コンフィグに書き込み)
#save clienv
----------------------------------------------------------------

◆A10 Networks
----------------------------------------------------------------
[ACOS]
#terminal length 0
#terminal length 24
----------------------------------------------------------------

◆Allied Telesis
----------------------------------------------------------------
[CentreCOM]
(config)# no service terminal-length
(config)# service terminal-length 24
----------------------------------------------------------------

TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | 知識 | このブログの読者になる | 更新情報をチェックする

F5 BIG IP show running config

F5 big-ipでshow running configを取得する方法。
--------------------------------------------------------------------------
■ログ取得その1
#tmsh
(tmos)#show running-config
Display all 250 items? (y/n)

--------------------------------------------------------------------------

これだと毎回聞かれるのでめんどくさい。
Ciscoでいうterminal length 0的なコマンドがほしい。
F5 big-ip v11以降だと以下のコマンドが使える。
--------------------------------------------------------------------------
■ログ取得その2
#tmsh
(tmos)#show running-config one-line

--------------------------------------------------------------------------

F5 big-ip v10より以前だとtmshに入らずshell(bash)からの
パイプ渡しででも取得可能かな。
--------------------------------------------------------------------------
■ログ取得その3
# yes | tmsh show running-config

--------------------------------------------------------------------------

F5 big-ip v10より以前だとterminal length 0的なコマンドもある。
--------------------------------------------------------------------------
■ログ取得その4
無効にする方法
#tmsh
(tmos)#modify cli preference pager disabled

有効にする方法
#tmsh
(tmos)#modify cli preference pager enabled

--------------------------------------------------------------------------

F5はrunning-configでのコンフィグ流し込みリストアなどはできないが、
running-configも取得しておくと何かと便利。

バックアップやリストアはGUIからUCSで実施しましょう!!






TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | F5 | このブログの読者になる | 更新情報をチェックする

NAT NAPT IPマスカレード違い

NAT NAPT IPマスカレード違い

■NAT(Network Address Translation)
読み方:ナット
IPアドレスを1対1で変換する。
グローバルIP一つに対してローカルIPを一つ紐づける。
外部(インターネット)から内部機器へ接続する場合が多い。
また内部から外部へ接続する際にも変換可能。

■NAPT(Network Address and Port Translation)
読み方:ナプト
IPアドレスを1対多で変換する。変換方法はIPアドレスとポートの組み合わせで行う。
内部機器から外部(インターネット)に接続する場合が多い。

■IPマスカレード(IP Masquerade)
読み方:アイピーマスカレード
基本的にはNAPTと同じ動作をする。
元々はLINUXにおける機能名称である。
古い人間にはこちらの呼び方のほうが馴染みがあるかも。

■PAT(Port Address Translation)
読み方:パット
基本的にはNAPTと同じ動作をする。
CISCO(シスコ)用語となる。

■ENAT(Enhanced NAT)
読み方:イーナット
基本的にはNAPTと同じ動作をする。

■NATオーバーロード
読み方:ナットオーバーロード
基本的にはNAPTと同じ動作をする。

ちなみに「IPマスカレード」「ENAT」「PAT」「NATオーバーロード」
と呼び方はいろいろあるが、RFC2663で「NAPT」という呼び方に
名称を統一しているので胸を張ってNAPTといいましょう!

電機屋さんで販売しているブロードバンドルータ(インターネット接続用)の
機能でNATと記載があるものはほとんどの場合NAPTのことを言っています。
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | NAT | このブログの読者になる | 更新情報をチェックする

Catalyst NAT サポート

Cisco機器なら機種関係なくNATできると思ってる人が意外といる。
実際ルータと言われるCisco機器はできるのだがL3スイッチだと
出来ない場合が多い。

以下が、L3スイッチでNAT可能な機器一覧となる
WS000083.JPG
WS000084.JPG

というわけでL3スイッチの場合、馴染みのある機種はほぼ
NAT不可となります。普通にルータを購入しましょう!!
TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | NAT | このブログの読者になる | 更新情報をチェックする

Fortigate DNS server gui

FortigateってデフォルトでDNSサーバ機能は無効になってるんですよね。
そしてバージョンが変わって有効にする方法が変わってる。
FortiOS4.0のDNSサーバGUI設定方法

ここからはFortiOS5.0, FortiOS6.0でのDNSサーバ機能を
有効にする方法を記載します。

1.DNSサーバ機能が無効になっていることを確認
左ペインの[ネットワーク]に[DNS]しかないことを確認
WS0000800.jpg

2.DNSサーバ機能を有効にしていきます
システム>FeatureVisibility>その他のフィーチャー>DNSデータベース
チェックを入れてOKを選択
WS000086.JPG

右側の+を選択すると詳細な内容が確認できます
WS000089.JPG

3.DNSサーバ機能が有効になったことを確認
左ペインの[ネットワーク]に[DNSサーバ]が表示されたことを確認
WS000090.JPG

-------------------------------------------------------
それ以外の[FeatureVisibility]設定項目
緑色になってるのは有効、グレーは無効。
FeatureVisibility1.JPG

FeatureVisibility2.JPG

FeatureVisibility3.JPG

FeatureVisibility4.JPG

FeatureVisibility5.JPG

FeatureVisibility6.JPG

FeatureVisibility7.JPG

FeatureVisibility8.JPG

FeatureVisibility9.JPG

FeatureVisibility10.JPG

FeatureVisibility11.JPG

FeatureVisibility12.JPG

FeatureVisibility13.JPG

TOP OF THE NETWORK×NETWORK
NETWORK×NETWORK
posted by シスコ | Comment(0) | Fortigate | このブログの読者になる | 更新情報をチェックする